Roadmapping Unavailable

Incident Report for Roadmunk

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 13:49 UTC

Monitoring

Availability of the roadmapping feature is restored. We continue to closely monitor performance and availability.
Posted Mar 19, 2025 - 20:27 UTC

Update

The roadmapping feature is currently unavailable. We are currently investigating performance degradation affecting the general availability of roadmapping in North America.
Posted Mar 19, 2025 - 19:56 UTC

Update

The roadmapping feature is currently unavailable. We are currently investigating performance degradation affecting the general availability of roadmapping in North America.
Posted Mar 19, 2025 - 19:26 UTC

Investigating

We are currently investigating a performance degradation of asynchronous functionality such as publishing, roadmap duplication and synchronization of roadmap items with 3rd party integrations.
Posted Mar 19, 2025 - 16:46 UTC
This incident affected: Roadmapping and Integrations.